Start a conversation

Error: 'A connection attempt failed because the connected party did not properly respond...' when adding an IMAP data source

Answer

PROBLEM

When trying to add an IMAP based data source (journal mailbox) under Configuration > Mail Server to Archive the following error is shown:

Failed during: Testing connection
Details: Could not perform test of connection. Details: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 192.168.0.1:8019 


Debug logs across ASPNET\UI and Core2 read:

2013-09-11,16:52:24,370,1,"#00000E90","#00000007","info ","MailServerWizard","MSCreate: Test Connection..." 
2013-09-11,16:52:24,371,1,"#00000E90","#00000007","info ","MailServerWizard","MSCreate: Preparing for test process" 
2013-09-11,16:52:24,501,1,"#00003DF8","#00000036","info ","DSTest","CreateTest. Type: Imap" 
2013-09-11,16:52:24,504,1,"#00003DF8","#00000036","info ","ProvidersFactory","CreateTest. Type: Imap" 
2013-09-11,16:52:24,508,1,"#00003DF8","#00000036","info ","ImapProviderBuilder",">> CreateTest" 
2013-09-11,16:52:24,546,1,"#00003DF8","#00000036","info ","ImapProviderBuilder","<< CreateTest" 
2013-09-11,16:52:24,546,1,"#00003DF8","#00000036","info ","ProvidersFactory","Test is ready: MArc.DS.ImapProviderTest" 
2013-09-11,16:53:06,657,1,"#00000E90","#00000007","error ","MailServerWizard","ERROR:MSCreate: MailServer test failed - System.Net.Sockets.SocketException (0x80004005): A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 192.168.0.1:8019 

 

Where 192.168.0.1 is the IP of the GFI Archiver server.


The Core (Core2 on version 2013 or older) service is still running and performing all other tasks normally.

ENVIRONMENT

  • GFI Archiver
  • GFI Archiver is installed on a server which has the Hyper-V role installed

SOLUTION

In the first case:

This situation was observed on a server which had the Hyper-V role installed, but it was actually not being used. Normally production software should not be installed on a server which hosts virtual machines. GFI Archiver would work fine if installed within a virtual machine itself.

The issue was addressed by uninstalling the not needed Hyper-V role from the server.


In the second case:

The system also ran on a Hyper-V environment. The situation was solved by removing / re-adding the "virtual network adapter" on Windows level. Further details on this are not known.

CAUSE

The cause seems to be related to Hyper-V and virtual network adapters. The situation is not clear though.

Choose files or drag and drop files
Was this article helpful?
Yes
No
  1. Priyanka Bhotika

  2. Posted
  3. Updated

Comments