Overview
The Archiver Update Users tool is useful after having changed users, recovering deleted users, or changing domains to restore access to mail that may already be archived.
Diagnosis
After performing an Archiver server migration to the new domain the user reports they are unable to see any mail on the system for the signed-in user. Mail was found for this user while the system was connected to the old domain. This can occur while switching from AD to GFI Directory or vice versa as well.
Solution
WARNING!! - Incorrectly completing these steps can prevent you from accessing your mail. Read the entire set of instructions first and verify your environment is compatible. If any of the settings do not match do not continue without first contacting GFI Support.
Considerations
To restore access to the user's mail on the new domain the following considerations must be taken.
- This tool can only be used if the users' logon name in the new domain is identical to the logon name in the old domain (attribute: sAMAccountName)
- Example of an entry that can be updated by this tool:
- Old username: OLDDOMAIN\JohnDoe
- New username: NEWDOMAIN\JohnDoe
Note: If usernames have changed you can provide access to the original mailbox via User Access Control
- It is recommended to use this tool before resuming archival
- Rebuild the indexes of the Archive Stores after using this tool - this can be done at a later point in time and can take a significant amount of time.
However, it should be noted that rebuilding the indexes is critical after such a migration/change since ownership information could be cached in these indexes. Even if the indexes appear healthy, they need to be rebuilt at the earliest to avoid issues with DB searches.
Download
This tool/script should be used only on installations running the following versions (i.e., do not use it on versions earlier than 2013):
- GFI Archiver 2015 SR1 or newer: 20150218 or newer
- GFI Archiver 2015: 20141117
- GFI MailArchiver 2014: 20140616
- GFI MailArchiver 2013: 20130510, 20130704, 20130723, 20131111
Process
- Create a backup of the Archive Stores (refer to the product manual
details); - Extract the zip archive to the root GFI Archiver folder. Make sure
that you see a folder named 'UpdateUsers' with the relevant files; - Stop the GFI Archiver Store Service service;
- Execute MAUpdateUsers.exe;
- Fill out the Archive Store Properties section
- MSSQL: SQL server instance, database name, username (SA) and
password. - Firebird: Full path including filename to the FDB file;
- MSSQL: SQL server instance, database name, username (SA) and
- Enable the 'Is Domain Name changed?' check-box and fill in the
details.
- Enter the old and new domain names. The syntax should be
'DOMAIN', where DOMAIN is the NetBIOS name of the domains in
question;
- Enter the old and new domain names. The syntax should be
- Click on Start;
- A pop-up window will appear once all users have been updated;
- Repeat the process for the other Archive Stores;
- Restart the GFI Archiver Store Service service.
Testing
After executing the tool, once time has been given for the system to index the mail, users should be able to see their email from the original domain under their new domain Archiver account by accessing it from the Archiver console > Archive tab.