Overview
When attempting to perform an export of archived material to PST the tools give the error "Error when creating PST file." The article below gives background on solutions for known causes of this error to occur.
Diagnosis
A client attempting to export their email to PST file is receiving the error after starting use of the tool and would like to perform the export successfully. The system is failing to store the found content as it fails to create the PST file it will be storing the content in.
Solution
There are a few items to check when experiencing this error. The database creation must occur before any mail for the time period is able to be stored.
Disk Space
First, let's verify there is disk space on the device that will allow the system to create the database. If the system does not have any space left the failure to create the pst will occur and content will be unable to be written.
- Navigate to "This PC"
- Locate the drive where Archiver is installed and where you are saving the file to
- Check the drive for free drive space and make sure there is room for the tool to function
- If necessary back up or delete files to free space on the drive
- After freeing drive space attempt running the tool again and confirm if the PST was able to be created
Correct Bitness
As discussed in the Archiver Requirements for Microsoft Outlook or CDO/MAPI it is indicated that the tool must be running the matching bitness of the tool it is using. See below.
- If a 32-bit version of Microsoft Outlook or CDO/MAPI is installed, ensure to use the 32-bit versions of the Import-Export Tool and the Mailbox Restore tool.
- If a 64-bit version of Microsoft Outlook is installed, ensure to use the 64-bit versions of the Import-Export Tool and the Mailbox Restore tool.
With the matching tool the system should no longer receive errors on the creation of the PST file.
Redemption.dll
Additionally another point of failure that can cause this error has to do with the .dll files themselves. We have identified 2 that need replacement if the issue continues after the above fixes. Follow the steps from Archiver Failure When Importing/Exporting via PST Files.
Testing
After each of the listed possible fixes attempt to run the appropriate tool again with the same settings to write to a .pst file, and the file should be created without error if the issue is resolved.