Overview
The Mailbox Restore tool provides the facility to restore emails archived within Archiver Archive Stores to a mailbox in Microsoft Exchange Server. For example, use Mailbox Restore to restore emails for deleted mailboxes.
Diagnosis
Administrators may need to restore old emails to a user's mailbox to access critical mail. Various errors can occur when the appropriate rights to the user's mailbox have not been granted along with Exchange permissions.
Prerequisites
Mailbox Restore tool is available in 32-bit and 64-bit.
- Use the 32-bit version when using MAPI Client/CDO or Microsoft Outlook 32-bit.
- Use the 64-bit version when using Microsoft Outlook 64-bit.
Mailbox restore tool needs permission on GFI Archiver Store and Microsoft Exchange mailbox.
Exchange Autodiscovery must be enabled for the tool to function.
Solution
Follow these steps to use the tool:
NOTE: The tool can also be launched in German, Spanish and Italian.
- Launch the Mailbox Restore tool from the GFI Archiver program group (Start > Programs > GFI Archiver > Mailbox Restore) using the account assigned permissions as per the article above.
Alternatively the executable is located under the installation directory in the MailboxRestore directory. (Default is ..\Program Files\GFI\Archiver\MailboxRestore\MailboxRestore.exe) - Select a mailbox to restore from the Restore from Mailbox field either using the drop down or manual entry.
- Enter information in this field using format:
[domain]\[mailbox alias]
- For example: 'MYDOMAIN\JSmith'.
- Enter information in this field using format:
- Enter the mailbox to restore emails to in the To mailbox field.
- Enter information in this field using format:
[mailbox alias]
- For example: 'JSmith'.
- Enter information in this field using format:
- If Exchange Online (Microsoft 365) is selected Enter the password of the user whose mailbox is the email recipient.
- Select All messages to restore all messages or specify a date range on Messages from and Messages to fields.
- Click Start for mailbox restore process.
- The system will ask for the credentials to the User mailbox you are restoring to
Alternatively, the Mailbox Restore tool can be used to export a mailbox to a PST file:
- Start the Mailbox Restore tool.
- Choose the source mailbox to export from.
- Type in the full path to the target file (i.e. e:\export\bob.pst) into the To Mailbox field.
- Click the Start button.
Note: This feature requires Microsoft Outlook. For details, please refer to GFI Archiver's Microsoft Outlook or CDO/MAPI requirements.
Testing
Once the steps are completed, the archived mailboxes are restored, and the user can view it in their respective folders within their mail tool, i.e. Outlook after synchronization with the Microsoft Exchange store.
Related Article
Launching GFI Archiver Mailbox Restore Tool in Different Languages