Overview
This article will discuss actions to take after moving to a new AD server while utilizing Archiver
Diagnosis
There are two distinct ways users can be migrated when moving to a new AD server. Archiver can relate mail to the users either when using the same username or if the username has changed. In either case the goal is for users to have access to their original mailboxes in the new environment. See the steps below for each situation.
NOTE: This article discusses the users migration specifically. If you are looking for steps to migrate the server content refer to Moving GFI Archiver to a New Server
Solution
Same Username - Tool: MAUpdateUsers
This tool can only update users if their username is identical in both, the old and the new domain:
- Example of entries that can be updated by this tool:
- Old username: OLDDOMAIN\JohnDoe
- New username: NEWDOMAIN\JohnDoe
- Example of entries that cannot be updated by this tool:
- Old username: OLDDOMAIN\JohnDoe
- New username: NEWDOMAIN\JD
This tool was designed to help migrate GFI Archiver user mailboxes when migrating GFI Archiver to a new Active Directory domain.
This tool must be run in the new domain after GFI Archiver was installed in it. First, install GFI Archiver in the new domain, and enable journaling and archiving. Then attach the old GFI Archiver archive stores to the new installation and then run this tool.
This tool/script should be used only on installations running the following versions:
- GFI Archiver 2015 SR1: 20150218
- GFI Archiver 2015: 20141117
- GFI MailArchiver 2014: 20140616
- GFI MailArchiver 2013: 20130510, 20130704, 20130723, 20131111
Please ensure to read the readme.txt bundled with the ZIP file. It is recommended to take a backup of the system including data (Archive Stores) before using this tool/script. Please specify the OLD and NEW domains in capital letters.
EXCEPTION: If before the migration, usernames are changed to reflect the new domain format, the tool will not find a match, since the AD change is not reflected in the SQL DB, even if the WebUI works to log in with the new username on the old domain. For this to work, UPDATE statements should be run for each user in each Archiver SQL DB.
- Download the tool/script (see above).
- Read the readme.txt which is bundled with ZIP file for usage instructions.
Usernames Changed - Access Control Method
Without running this tool, users will have two mailboxes; One containing all emails that were archived before the domain migration and one containing all emails that were/are archived after the domain migration.
The old mailbox will appear as "deleted" and permissions to it must be granted via Access Control. This tool will update the user's entries in the Archive Stores to match the users in the new Active Directory domain in order for a user to access their email via a single mailbox.
Follow the steps in Defining User Access Control for Specific Users in GFI Archiver to allow the new username access to the old mailbox. This allows the end user to access their mail in the new environment for both the old and new mailboxes.