Overview
This article provides information on deleting emails in Archiver and special precautions you must take before doing so.
Diagnosis
Administrators are requesting to delete email from the entire organization so it is no longer accessible or allow users to delete emails as they see fit. Users may report they are unable to delete email or the option is unavailable. Deleting email should be performed with extreme caution.
IMPORTANT: Archiver is an email archiving solution which enables companies to be compliant to legislation, such as the Sarbanes-Oxley Act. This legislation states that companies should ensure that all inbound and outbound emails, particularly those pertaining to an audit or review, be kept for seven years, during which time these records must be non-erasable and non-rewritable. Consider the usage of the deletion features carefully.
Solution
The deletion option is disabled by default. To enable deletion, follow the steps below:
- Enable email deletion via Configuration > Email Deletion.
- Make sure that the "Delete emails" permission is granted only to the desired users/groups via Configuration > Roles and Permissions.
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Note: If the "Leave a copy of the item in the Archive Stores accessible by a user with View All Items permission." option is not checked when enabling deletion, deleting mail will remove it from the SQL database as well as from Archiver. Ref: 3795167
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The following delete methods are available:
- Via the Archive tab within the web page:
- Items - Available on a per-item basis, bulk deletion is not possible.
- Folders - Available only in GFI MailArchiver 2014 or later.
- Via IMAP (e.g., when accessing GFI MailArchiver via Thunderbird using IMAP4):
- Items and folders - Available only in GFI MailArchiver 2014 or later.
- Via the Microsoft Outlook Connector:
- Items and folders - Available only in GFI MailArchiver 2014 or later.
Note: It is not possible to delete files archived via the File Archive Assistant nor their folders within the Files folder structure.
Testing
After enabling Email Deletion and providing access to the appropriate group or user, access the Archiver web console logged in as this user. Use the Delete button as discussed in the Delete method above. After deleting the mail, re-load the page and attempt to access the mail again and it should no longer be accessible via the Archiver product.