Overview
Consider the following scenario:
- User starts the Mailbox Restore tool.
- Chooses a source mailbox (DOMAIN\UserA).
- Enters the target mailbox in the same format (
DOMAIN\UserA
) - On clicking 'Start' the GFI Archiver Mailbox Restore tool throws the error:
Could Not Find Mailbox
Whereas, the debug log at ..\MailboxRestore\DebugLogs\MBRestore.log reads:
2013-06-19,13:20:12,972,1,"#00000628","#0000000A","info ","MBRestore","Testing Mailbox..." 2013-06-19,13:20:12,994,1,"#00000628","#0000000A","info ","MBRestore","Exchange Server: " 2013-06-19,13:20:12,994,1,"#00000628","#0000000A","error ","MBRestore","error:Failed Test: Could Not Find Mailbox"
Environment
- GFI Archiver
- Microsoft Exchange
- All supported environments
Root Cause
The 'To Mailbox' field must be entered in a specific way.
Resolution
Enter the address of the destination folder ('To Mailbox' field) in the following way, depending on the version of Microsoft Exchange:
- When restoring to a mailbox on Microsoft Exchange 2013:
- Enter the email address of the target mailbox in the 'To Mailbox' field.
- Enter in the format:
[UserA@DOMAIN]
- When restoring to a mailbox on Microsoft Exchange 2010 or earlier:
- Enter the alias of the target mailbox in the 'To Mailbox' field without the domain part.
- Enter in the format:
[UserA]
- Enter in the format:
- Do not to use the domain part (DOMAIN\UserA) as the Restore from Mailbox field might suggest.
- Enter the alias of the target mailbox in the 'To Mailbox' field without the domain part.
- Note: The alias can differ from the user login name.
Related Article
Using GFI Archiver Mailbox Restore Tool