Overview
When accessing the Archiver web interface, you receive the following error:
HTTP 404 Not Found: The webpage cannot be found.
Diagnosis
The Archiver files could not be found because the web site was not started.
Solution
- Open the Services Console (services.msc)
- Check that the IIS Admin Service and its dependencies are started, restarting the service if necessary.
- Verify that the website is started:
- Go to Start > Administrative Tools > Internet Information Services (IIS) Manager.
- Expand the machine node, and expand Sites.
- Right-click the website that hosts GFI Archiver, and select Manage Website > Restart.
- Make sure the Application Pool is started:
- From Internet Information Services (IIS) Manager, expand the machine node and select Application Pools.
- Confirm GFI Archiver Application Pool (ArchiverPool) is started.
- Verify the Application Pool is set to ASP.NET v4.0 and Network Service:
- Go to Internet Information Services (IIS) Manager > Application Pools
- Go to GFI Archiver Application Pool and select Advanced Settings.
- From the Advanced Settings window, go to General > .NET Framework Version and make sure it's using v4.0.
- From the Advanced Settings window, go to Process Model > Identity and check that it's using Network Service.
- Confirm ASP.NET has been registered with IIS and pages are set to allow using the article Registering ASP NET with IIS Web Server.
Note: If issues continue after following these steps you will need to troubleshoot IIS itself by following the guide from Microsoft for troubleshooting an "HTTP 404 - File not found" error message on a server that is running IIS.
Testing
After performing the solution to confirm you have access to the web interface, navigate to the Archiver URL and you should see a page requesting sign in (seen below), or will automatically be logged in depending on configured options for sign in.