Overview
When accessing the Archiver web interface, you might encounter the following error:
HTTP 500 Internal Server Error: The Website cannot display the page. |
This article provides information about the error's root cause and outlines the steps on how to resolve the error.
Environment
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Archiver
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All supported environments
Root Cause
Archiver might be missing some required components to work properly.
Resolution
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Verify if the Internet Information Services/IIS Admin service and its dependencies are started/running.
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Check if the website is started/running:
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Go to Start > Administrative Tools > IIS Manager.
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Expand the machine node and the Sites option.
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Right-click the website that hosts GFI Archiver and select the Restart option.
Example: Default Web Site
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On IIS Manager's main interface, expand the machine node, and select the Application Pools option. Ensure that the GFI Archiver Application Pool is running/started.
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Ensure the GFI Archiver Application Pool is set to ASP.NET v4.0 and Network Service:
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Go to IIS Manager > Application Pools.
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Go to the GFI Archiver Application Pool and click the Advanced Settings option.
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On the Advanced Settings window, go to General > .NET Framework Version and verify if the application pool is using .NET Framework 4.0.
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Go to Process Model > Identity to check if the application pool identity is set to the Network Service option.
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Confirm if all IIS prerequisites listed below are installed:
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ASP.NET
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.NET extensibility
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ISAPI extensions
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ISAPI filters
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Windows authentication
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Verify if ASP.NET has been registered with IIS, and the pages are enabled.