Overview
This article describes the error and its resolution which occurs when using the Mailbox Restore tool to restore a GFI Archiver mailbox to an Exchange 2013 server.
"Failed to Connect to Exchange Mailbox. Check your permissions."
The restore might fail with MAPI_E_NETWORK_ERROR logging from version 8.1. Examining ...\MailboxRestore\DebugLogs\MBRestore.txt from a 12.4 (20180528) version shows the following:
2012-12-12,16:33:04,489,1,"#00000A9C","#0000000B","info ","MBRestore","Testing Mailbox..." 2012-12-12,16:33:04,958,1,"#00000A9C","#0000000B","info ","MBRestore","Exchange Server: EXCHANGE" 2012-12-12,16:33:07,036,1,"#00000A9C","#0000000B","info ","MBRestore","User: targetuser@domain.com" 2012-12-12,16:33:08,771,1,"#00000A9C","#0000000B","warning","MBRestore","warning:Connect Failed Error in IMsgServiceAdmin::ConfigureMsgService: MAPI_E_NETWORK_ERROR" 2012-12-12,16:33:08,802,1,"#00000A9C","#0000000B","error ","MBRestore","error:Connect Failed2 Error in IMsgServiceAdmin::ConfigureMsgService: MAPI_E_NETWORK_ERROR" 2012-12-12,16:33:08,802,1,"#00000A9C","#0000000B","error ","MBRestore","error:Failed Test: Failed to Connect to Exchange Mailbox. Check your Permissions." 2012-12-12,16:50:43,740,1,"#00000A9C","#00000002","error ","MBRestore","error:Cleanup Error: Not logged on. Please log on first"
Environment
- GFI Archiver Build 20150218 and older
- Exchange 2013
- CDO 1.2.1 Feb 2013 Update (version: 6.5.8309.0 or newer) or Outlook 2007 (latest SP) is installed on the machine on which the Mailbox Restore tool is running on
- Other required permissions are set properly (for example, Full Access permissions of the logged on user to the target mailbox in Exchange 2013)
Root Cause
This is an environmental issue with yet-to-be determined cause; believed to be DNS, autodiscover and/or certificate issue
- Neither an Archiver server with MAPI CDO 1.2.1 or Outlook addresses this issue.
- Building a new server and installing fresh doesn't address the environmental issue.
Resolution
To resolve the issue permanently, it is recommended to upgrade and apply the patch provided below. You may also perform one of the workarounds mentioned below as a temporary resolution:
-
Upgrade
Upgrade and apply the patch for GFI Archiver 2015 SR1 BUILD 20150218. -
Workaround
- Double check correct permissions were set: Setting Permissions of Microsoft Exchange Mailboxes for Using GFI Archiver Mailbox Restore Tool
- Run MailboxRestore.exe.
- Fill in the Restore from Mailbox: and To Mailbox:
- Select Exchange Online (Microsoft 365, previously known as Microsoft Office 365).
- Fill in the password for the mailbox and start the restore.
Note: Exchange autodiscovery should be properly configured for this to work.
The URL that is tested should look as:https://autodiscover.<domain>.<tld>/autodiscover/autodiscover.xml
Using Wireshark, samples of the queries that are requested are as follows and in this order:-
autodiscover.aniadeco.ro: type A, class IN
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_autodiscover._tcp.aniadeco.ro: type SRV, class IN
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LDAPMessage searchResEntry(8) "CN=2016EXCH01,CN=Autodiscover,CN=Protocols,...
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-
Legacy workaround and resolution for Archiver 2015 SR1
Point the Exchange server's hostname (EXCHANGE) to the IP address of a DC by following the steps mentioned below:
NOTES:
This might have undesired side effects - be very careful doing this! Think about the server roles and what such a change might cause. It is not recommended to leave this workaround in place for good.- Create backup of
c:\windows\system32\drivers\etc\hosts.
- Open the hosts file in Notepad.
- Add this line (using the values of the customer's environment):
EXCHANGE 192.168.0.1
Note: This step is vital and forms part of the identification process of this known issue.
- Create backup of