Answer
PROBLEM
External emails are not being archived while having the following settings configured under Configuration > Archive Restrictions:
- Using an inclusion list & Only archive item if all recipients and senders are in the restriction list
- No external email addresses have been added to the list
ENVIRONMENT
- Archiver
- All supported environments
SOLUTION
- Open the web page
- Navigate to Configuration > Archive Restrictions
- Click on Change Settings
- Add external email addresses to the list
- Keep in mind that in the selected mode, emails are only getting archived if the sender as well as all recipients are on the list - this relates to internal as well as external email addresses / users)
- Reconsider if the selected mode is the correct choice as it is very restrictive and change it if another mode suits the environment better
CAUSE
The Archive Restrictions feature is configured in a way to not archive the emails in question.