Answer
PROBLEM
The Windows Application Event Log lists warnings similar to:
Event ID: 6310
Plugin LogScheduler reports exception. Logging: Submit failed.
Additional info: Could not find file 'C:\Program Files\GFI\Archiver\Core\Queue\6079ae51-a18a-4cd7-a9c2-9d87f052b1ff.eml'.
Email notification from GFI Archiver:
GFI Archiver failed to transfer the archived emails into the backend database.
The following error message was reported:
Could not find file 'C:\Program Files\GFI\Archiver\Core\Queue\f18e42a8-df63-41b9-a5e2-00186de19fb7.eml'
Debug logs indicate:
..\Core\Debuglogs\LogScheduler.log:
2009-10-26,16:23:48,428,1,"#00000E70","#00000015","warning","LogScheduler","Warning: Submit error - Could not find file 'C:\Program Files\GFI\Archiver\Core\Queue\87a424a5-0591-4a84-a111-aedd95f6af92.eml'."
2009-10-26,16:23:48,428,1,"#00000E70","#00000015","error ","LogScheduler","Error: Unknown external error: System.IO.FileNotFoundException: Could not find file 'C:\Program Files\GFI\Archiver\Core\Queue\87a424a5-0591-4a84-a111-aedd95f6af92.eml'.
;File name: 'C:\Program Files\GFI\Archiver\Core\Queue\87a424a5-0591-4a84-a111-aedd95f6af92.eml'
; at MArc.Logging.LogSubmit2.Process(Dictionary`2 envelopes, CSArchiving configuration)"
..\Store\Debuglogs\emailmessageupload.log:
2009-10-26,16:23:46,977,1,"#000005A4","#00000017","error ","EmailMessageUpload","error: Upload - Could not find file 'C:\Program Files\GFI\Archiver\Core\Queue\87a424a5-0591-4a84-a111-aedd95f6af92.eml'."
2009-10-26,16:23:46,977,1,"#000005A4","#00000017","warning","EmailMessageUpload","warning: Rolling back - UploadError"
Notes:
- If using GFI MailArchiver 2014 or older and archiving into an Archive Store which uses a binary folder, the binary folder of the archive store grows much faster than normal
- Above errors can also refer to .body or .emc files rather than .eml files
ENVIRONMENT
- GFI Archiver
- All supported environments
SOLUTION
Step 1 - Ensure that no 3rd party application is interfering with GFI Archiver:
To prevent this issue from occurring again in the future, you will have to exclude the third party application from scanning the GFI Archiver installation directory, as well as the location where the binary folders reside.
Step 2 - Clear up the Queue folder(s):
- Stop all GFI Archiver services
-
..\Core\Queue (used for regular archiving)
- Move all *.eml files from ..\Core\Queue to ..\Core\Pickup
- Delete all remaining files from ..\Core\Queue
- Open a command prompt and navigate to the folder ..\Core\Pickup
- Rename all eml-files to *.raw via the command: ren *.eml *.raw
-
..\MAIS\Queue (used when importing items)
- Move all *.eml files from ..\MAIS\Queue to ..\MAIS\Pickup
- Delete all remaining files from ..\MAIS\Queue
- Open a command prompt and navigate to the folder ..\MAIS\Pickup
- Rename all eml-files to *.q via the command: ren *.eml *.q
- Start all GFI Archiver services
CAUSE
This issue can occur when a third party application (such as anti-virus software) scans the GFI Archiver installation directory and locks or removes one of the files, preventing the item from being uploaded successfully to the archive store database.