Overview
If you notice issues during a search but can browse to the message manually or you realize one or more Archive Store Database indexing is not ending or stuck on rebuild you will need to rebuild the search Archive Store index.
This article outlines two different methods to rebuild an Archive Store Index for databases.
Diagnosis
Users notice issues during search, but can browse to the message manually within the Archiver Console > Archive tab. This is an indication that there may be corruption within the Search index.
Alternatively, administrators may see the Archive Stores under Configuration > Archive Stores and find that the Index State is stuck on rebuild or invalid.
Solution
Notes:
- Indexing can be a lengthy process and adds additional load to the system
- Depending on the number of items in an archive store, the items themselves and system performance, rebuilding an index can take anything from a few minutes to multiple days or even weeks
- It is not recommended to rebuild all indexes for all archive stores at the same time - it is often better to rebuild them one by one
Method 1 - Via Archive Stores
Using this method will keep the old index on disk while a new index is being built aside of the old one. Once the building of the new index is complete, the old index will be deleted.
Assuming the old index is still in a healthy state, the old index can be utilized for search queries while the new one is being built when using this method.
- Open the GFI Archiver web page.
- Navigate to Configuration > Archive Stores.
- Select the desired archive store.
- Click on Rebuild Index
Method 2 - Forced Rebuild
Using this method will remove the old index, then build a new one from scratch.
- Open the GFI Archiver web page.
- Navigate to Configuration > Archive Stores.
- Select the desired archive store.
- Click on Summary.
- Take a note of the Path to search index.
- Launch services.msc (Alternatively select Start > Programs > Windows Administrative Tools > Services)
- Stop the GFI Archiver Search service.
- Delete the Index Folder of the desired archive store from disk (the folder from step 5)
- Start the GFI Archiver Search service.
- GFI Archiver will detect that no index exists for the archive store and start to build a new one.
Please note that while Archiver is rebuilding the indexes from scratch, it won't show as 'rebuilding,' but instead, it may show up as Invalid. This is because the index is completely missing, corrupted, or unusable. Its progress cannot be tracked in the UI, but you can check your logs to partially track the same. Navigate to <GFI Root>\Archiver\Search\DebugLogs\Index.log and find any recent logs that look like these:
If you see a log notifying you of a Sync in bulk mode followed by a lot of New messages, then it is in the process of indexing your mail.
Additionally, every index will temporarily appear as invalid when you implement method 2, and this is because we guide you to stop the Archiver Search service while keeping the Core service running - and when the Core service tries to reach back to the Search service and fails to find it, that is expected to happen. This should be refreshed within a few minutes.
Testing
We can confirm the Index rebuild is ongoing by navigating to the Archiver Console > Configuration > Archive Stores and checking the Index status of the Archive Store. Specifically we will be looking for one of the three following states.
Pending | This is the state used before an index is going to start rebuilding. The search index will remain in Pending state if there are other indexes being rebuilt at that point in time. | |
Rebuilding | Rebuilding indicates that the Search service is indexing a whole database. The search index would change to this state should you click Rebuild Index within the GFI Archiver Configuration. The size of the database being indexed affects the duration of the rebuilding of the index. | |
Rebuilding Paused | The rebuilding index process is manually paused within the GFI Archiver Configuration. The index will remain in this state until Continue Indexing is clicked. |
When the Index rebuild is completed and the status goes back to Online , perform a search from the Archive tab of the console, and confirm mail from the time frame re-indexed is able to be found again.