Answer
PROBLEM
From a certain point in time (X) the following symptoms start to manifest:
- Outlook Connector do not show emails newer than X. It still synchronizes with the server without errors, but each synchronization shows that 0 emails got synchronized although new emails have been archived.
- The Archive Stores widget under the Home screen of the web interface shows that 0 Archived Emails for each archive store (even after the GFI MailArchiver services are running for a while)
- Indexing appears to have stopped at a certain point in time (for indexes running in normal mode). The number of indexed emails does not increase anymore since X.
- Users can still search within GFI MailArchiver without errors, but they only find emails older than the time X.
- Users accessing GFI MailArchiver via IMAP do not see emails newer than X.
Upon investigation it is determined that the following file is blank, does not contain any data and is 0 bytes in size:
..\GFI\MailArchiver\Store\Data\MaintenanceSettings.xml
ENVIRONMENT
- GFI MailArchiver 2014 or older
- Note that GFI Archiver 2015 and newer contains code to automatically recover from this situation and should not be affected
- All supported environments
SOLUTION
- Download http://ftp.gfisoftware.com/support/MARC/Skynet/MaintenanceSettings.zip
- Stop the GFI MailArchiver Store service
- Open the folder ..\GFI\MailArchiver\Store\Data
- Replace MaintenanceSettings.xml with the version found enclosed in the zip archive you downloaded in step 1
- Start the GFI MailArchiver Store service previously stopped in step 2
CAUSE
The mentioned file has become corrupt.