Overview
This article describes the issue and its resolution, when the Import Export Tool does not list folders that hold a high amount of items in the Mailbox and Folder Selection screen. Only folders with a small number of items are displayed.
For example, Folder1 with 99 items is listed, but Folder2 with 9999 is not listed.
The debug log ..\GFI\Archiver\MarcImportExport\DebugLogs\ExchPstExport.log
lists the following for each folder that is affected:
"warning","ExchPstExport","warning:Failed RootFolder (skipping): The server cannot service this request right now. Try again later."
Environment
- GFI Archiver
- Microsoft Exchange 2010
Root Cause
The Exchange Throttling Policy is limiting applications that use the EWS API. Microsoft Exchange 2010 Service Pack 1 introduced a default setting of 1000 for EWSFindCountLimit
.
Resolution
Create a new Exchange Throttling Policy that does not limit EWS usage and assign it to the user that is performing the export. As for the following steps, we are assuming the user who accesses the mailboxes to export is UserA:
- Open the Exchange Shell on the Microsoft Exchange server.
- Run the following cmdlets:
-
New-ThrottlingPolicy GFIMARC
-
Set-ThrottlingPolicy -Identity GFIMARC -EWSFindCountLimit $null
-
Set-Mailbox -Identity UserA -ThrottlingPolicy GFIMARC
-
- Restart the World Wide Web Publishing Service on the Microsoft Exchange CAS server for the changes to take effect.