Overview
When accessing the MailArchiver web interface, a specific user receives the following error:
Non controlled 500 error. Please try test manually!
Other users are still able to access the console with normal functionality.
Diagnosis
If the user experiences the 'Non controlled 500 error. Please try test manually!' try logging in as another user. If other users are able to successfully log in and access the console this is an indication of a corrupt profile. Individual profiles can be recreated using the solution below.
Solution
Follow these steps to resolve this issue:
- On the GFI MailArchiver server, go to the installation directory \ Profiles directory as follows:
- ..\Program Files\GFI\Archiver\ASPNET\UI\Profiles or
- ..\Program Files (x86)\GFI\Archiver\ASPNET\UI\Profiles
- Delete the user profile in question. The file name is in the format of DOMAIN_User as shown below.
- Navigate to Start > Run > type 'services.msc' and hit Enter
- Locate the GFI Archiver Core Service, right click and Restart the Core service.
Testing
After restarting the service open the GFI Archiver Console again and log in as the problematic user. This triggers the profile to be recreated on the back end and should allow logon with the appropriate access level provided under Roles and Permissions.
Verifying the profile is recreated can be done by navigating to the ..\GFI\Archiver\ASPNET\UI\Profiles directory and confirming the new version of the deleted file is in place.
If the issues continue review the How to Reset Roles and Permissions article to reset the system access to default settings.
Related Articles
How to Reset Roles and Permissions