Overview
This article will provide the process for using and generating reports in Archiver using the MailInsights module
Diagnosis
Administrators may want to gather data on the content stored within the Archive Stores. Use this feature to generate management and HR reports that provide insight on email and resource use or misuse, email usage and trends. Reports are sent by email using the configured SMTP server and can be sent to the logged in user or Forwarded to specific users.
Prerequisites
SMTP Server configured in Configuration > General Settings
Access to MailInsights configured in Roles and Permissions
Note: Contact your System Administrator if you do not have access to MailInsights
Solution
Follow the steps below to create the required report.
To generate a report manually:
- Launch the GFI Archiver Web Console
- Select MailInsights tab and choose the desired report.
The available reports are:
Report name Description Communication Flow Monitor user/group communication patterns inside and outside the organization.
WebMail Use Identify top users exchanging email with WebMail services. Identifies potential data leakages and inappropriate email use. Email Responsiveness Gain insight into the average time it takes users to reply to internal and external email.
Storage Use Understand the impact of attachments on email storage costs. Create appropriate retention policies to control email-related storage space.
Inactive Accounts Returns a list of user accounts that received email but have not replied within the specified time.
Inappropriate Words Track inappropriate language in email that violates company policy.
Internal Spammers Find out which internal users tend to include too many recipients in the To/CC/BCC fields.
Outside Office Hours Returns a list of internal mail accounts with sending activity outside office hours. Spot behavior which may need more investigation.
Data Leakage Detection Identify emails with major credit card numbers and US Social Security numbers, or other confidential documents and information.
Job Search Identify sent or received emails that contain resumes, or are addressed to job search sites.
Phrase Search Search for specific terms or phrases within archived emails.
User Traffic View the number of emails exchanged between selected users or groups and their contacts.
Email Topics Lists topics and common words found within emails exchanged between selected users or groups and their contacts.
Email Performance Indicators Analyze sent and received emails to classify users' productivity according to a set of predefined performance indicators.
Large Emails report Identify large emails that can be taking up unwanted space in your archive. Email attachments are classified according to specific categories. - Use available filters by selecting a value to filter by.
- (Optional) In the Forward to field, enter the recipient email address.
NOTE
When using the email forwarding option, the report is received by the user generating the report and by any users specified in the Forward to field. You can insert multiple email addresses separated by ';' - Click Send Report, located at the bottom of each report page.
Generating Report based on a schedule
To schedule a report:
- Select MailInsights tab and choose desired report.
- Use available filters by selecting a value to filter by.
- Click Schedule.
- In the Report Name field, enter a meaningful name for your report.
- (Optional) In the Forward to field, enter the recipient (or recipients) email address.
- From the Schedule Report drop down list, select the report run frequency. Available options are: Daily, Weekly or Monthly.
- In the At field, specify the time.
- Click Save & Schedule Report.
Testing
After selecting Send report the information will be gathered and report will be sent via email to the indicated user. Check the report and verify it contains the needed data.