Overview
When running the Archive Store Wizard to attach a Microsoft SQL Server-based Archive Store, the database list (after logging in to the instance) is empty or the desired database is not listed.
Environment
- Archiver
- All supported environments
Root Cause
The wrong Archive Store type is selected in the Archive Store Wizard.
Resolution
- Make sure that no Archive Store is already attached to Archiver which connects to the same Microsoft SQL Server database.
- Verify that the Microsoft SQL Server database contains the regular tables (like dbo.arc, dbo.add, ..., dbo.gfi_marc_dle_db_version, etc.).
- Ensure that the correct Archive Store type is selected when starting the Archive Store Wizard. The type can be confirmed using the SQL query:
SELECT id
These are the basic types:
FROM gfi_marc_dle_db_version.- Microsoft SQL Server + File Storage (using a binary folder on disk)
- Microsoft SQL Server
- GFI MailArchiver 3 (legacy)
- GFI.MAR4.MsSqlFS.Eml = Microsoft SQL Server + File Storage
- GFI.MAR4.MsSql.Eml = Microsoft SQL Server
- A GUID number like 8F58E9CA-31C2-4528-8CE9-93CD07927522 = GFI MailArchiver 3
- Close the Archive Store Wizard and go through it again choosing the correct Archive Store type.
NOTES:
- Avoid using the "Back" button when using the Archive Store Wizard.
- Concerning this topic, GFI Archiver does not differentiate between Microsoft SQL Server Express and other Microsoft SQL Server editions.
- Always authenticate against the Microsoft SQL Server using SQL authentication and the SA login.