Overview
"Archiver: Email Upload Warning" error notification received when Emails stop being uploaded from Core/Queue to the Archive Store database
Diagnosis
Administrators are receiving an email notification that Archiver is experiencing a failure when writing email to the system with the title "Archiver: Email Upload Warning". This is generally caused by a failure to connect to the database and write email to the Archive Store varying from timeouts to full network connectivity failures.
After enabling and gathering Troubleshooting Logs administrators can view the following logs for similar errors to confirm the error is caused by a failure to connect to the database.
Core\DebugLogs\LogSubmit2.log
2011-03-09,12.39.25,062,1,"#00000794","#00000010","error ","LogSubmit2","Error: upload exception UploadError"
2011-03-09,12.39.25,062,1,"#00000794","#00000010","error ","LogSubmit2","Error: failed to submit. Message:System.Data.SqlClient.SqlException: A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server); at MArc.Logging.LogSubmit2.Process(Dictionary`2 envelopes, CSArchiving configuration)"
Store\DebugLogs\ErrorsDal.log
2011-03-09,12.39.51,296,1,"#000008C8","#0000000D","error ","ErrorsDal","error: (MsSql) FindMatch() FA -
;message: A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server)
Solution
Verifying that the protocols in use are enabled and adjusting timeout values allows the system to respond prior to receiving the network error and in turn preventing the error notification from being received.
Verifying Named Pipes is enabled
- Log in to the Microsoft SQL Server using admin credentials.
- Go to Start > Programs > Microsoft SQL Server > Configuration Tools > SQL Server Configuration Manager.
- In the SQL Server Configuration Manager, expand SQL Server Network Configuration, click Protocols.
- Enable Named Pipes and TCP/IP.
- Restart the Microsoft SQL Server services.
To configure the remote query timeout option
- Go to Start > Programs > Microsoft SQL Server > Configuration Tools > SQL Server Configuration Manager.
- In Object Explorer, right-click a server and select Properties.
- Click the Connections node.
- Under Remote server connections, in the Remote query timeout box, type or select a value from 0 through 2,147,483,647 to set the maximum number seconds for SQL Server to wait before timing out.
NOTE: It is suggested to have a timeout longer than the default of 2 minutes. This value can vary depending on the capacity of the network and load of the database server itself.
Testing
To test the solution to this error the server would need to experience a timeout again for the notification to be received. As such, continuing normal use of GFI Archiver will perform the action of writing mail to the database. Administrators should no longer receive errors after adjusting the above values.