Overview
If you see that user emails are not archiving, emails are stuck in the Microsoft Exchange journal mailbox or the Archive Store summary shows that emails or files have not been archiving then you should follow the steps below to verify settings, access and components are set to allow mail to be archived.
Diagnosis
Emails and Files may not be archived due to database failures, low disk space or Mail Enabled Users exceeds Licensed Users.
Archiver stops archiving for one or more domains and rebooting doesn't help.
GFI Archiver could stop archiving messages and files for domain connectivity issues, incorrect configuration, out of date database schema, large emails in the journal mailbox, enabled users exceeding licensed users or interference of third party anti-virus software.
NOTE: To confirm emails are not being archived, from GFI Archiver, navigate to Configuration > Archive Stores > click Summary of active archive store > Check Last Email Archived On.
SOLUTION
General Verification
- Confirm GFI Archiver is able to connect to journal mailbox and connection is active
- From GFI Archiver, navigate to Configuration > Mail Servers to Archive > select Journal Mailbox > click Edit > complete wizard and verify test is successful
- Ensure journal mailbox is set to Active
- Confirm GFI Archiver is able to connect to back end database
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From GFI Archiver, navigate to Configuration > Archive Stores > select the active Archive Store > click Edit > complete wizard and verify test is successful
- If using Microsoft SQL Server, we recommend using the SA account
NOTE: At minimum an account with DB Owner rights is required - If Archiver has not been archiving for some time and an "active Archive Store" does not exist since it was never created, you should go through Configuring New Archive Store Settings
- If using Microsoft SQL Server, we recommend using the SA account
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From GFI Archiver, navigate to Configuration > Archive Stores > select the active Archive Store > click Edit > complete wizard and verify test is successful
- Confirm the number of Mail Enabled Users does not exceed Licensed Users
- From GFI Archiver, navigate to Configuration > General > Change License Key
- Check the number of files in ..\GFI\Archiver\Core\Pickup and ..\GFI\Archiver\Core\Queue
- Having items in these folders is normal but items should pass through these folders quickly
- If no items are appearing in this folder refer to Troubleshooting issues with Journal Mailbox
- If there are files stuck in these folders or the same item is reprocessing continuously
- Restart the GFI Services via services.msc
- Refer to Troubleshooting Databases
Troubleshooting issues with Journal mailbox
- Confirm you can access the journal mailbox through OWA or Outlook
- If you cannot access this mailbox, chances are the account is locked out in Active Directory or the credentials you specified are incorrect
- If you can access the mailbox, however you are unable to connect to the Journaling mailbox through Archiver Configuration page, then please follow the article: Configuring a Journaling Mailbox
- If no emails are located in journal mailbox, confirm Journaling is enabled for the appropriate mailbox type
- Preparing Journal Mailbox in Microsoft Exchange Server
- Preparing the Journal Mailbox for Google Apps
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Preparing the Journal Mailbox for Kerio Connect
NOTE: Emails that were not sent to the Journal mailbox can be imported to Archiver by Using GFI Archiver Import/Export Tool for Importing Emails from Microsoft Exchange Mailboxes
- If emails are stuck in journal mailbox, check the total size of email and attachment and check for calendar items
- If there are large emails or calendar items present in journal mailbox, move the suspect item to a sub-folder to see if archiving will resume
- If using IMAP to connect to Journal mailbox, ensure the Microsoft Exchange IMAP4 service is set to automatic and started on the Microsoft Exchange server
- Resolve errors with Event ID: 1023 Source IMAP Error Event IMAP4SVC if they are occurring
Troubleshooting databases
- Confirm active archive store database size does not exceed recommended size limit, from GFI Archiver, navigate to Configuration > Archive Stores > click Summary of active archive store
- Microsoft SQL Server 2008 Express edition has a database size limit to 4GB
- Microsoft SQL Server 2008 R2 Express edition has a database size limit to 10GB
- Microsoft SQL Server 2012 Express edition has a database size limit to 10GB
- Microsoft SQL Server 2014 Express edition has a database size limit to 10GB
- Microsoft SQL Server 2016 Express edition has a database size limit to 10GB
- Microsoft SQL Server Standard Edition has an upper limit of 524 Petabytes
- Firebird 2 GB
- Ensure Best practices for GFI Archiver are being followed
- Ensure antivirus software is not scanning GFI directories
- If using Microsoft SQL Server databases
- Ensure that GFI Archiver has a stable connection to Microsoft SQL server and that Microsoft SQL Server has enough resources to cope with the load
- Run a scan to check for hard disk errors using Microsoft chkdsk
- Run an integrity check on the problematic GFI Archiver database
- Ensure that the timeout values from Microsoft SQL Server itself (including connection timeout) are set to a high value (not the default of 2 minutes)
- Ensure that the autogrowth of the DATA and TRANSACTION LOG are set to a fixed size (not percentage) and ensure that the database has enough space to grow automatically
If only certain emails are not being archived:
- Check Configuration > Archive Restrictions and remove any conflicting rules
- Check Configuration > Archiving Scope and verify the type of mail is selected for Archiving
- Check Configuration > Retention Policies and verify the
- Confirm that journaling is enabled for all Microsoft Exchange databases and working correctly in Microsoft Exchange
Testing
After verifying the settings are in place and mail should be flowing from GFI Archiver, navigate to Configuration > Archive Stores > click Summary of active archive store > Check Last Email Archived On. The date should be updated and show the current time if the archiving functionality has been restored.
If errors are still occurring Gather Troubleshooting Logs, provide information on what type of Journal Mailbox is configured as well as the type of database in use. Additionally, if files are stuck in the Archiver Queues if you are able to release a copy, Zip the suspected files and provide them with the troubleshooting logs for review.