Overview
This article describes the issue and its resolution, which occurs when a search returns zero or incorrect results.
Environment
- Archiver
- All supported environments
Root Cause
Indexing issues can be caused by several different issues: anti-virus software, unexpected server shutdown, configuration issues, etc.
Resolution
- Confirm that:
- Antivirus software is excluded from scanning Archiver folders.
- Search indexes are located on the server where Archiver is installed.
- Disk space is available.
- No other index is present in the same folder.
- If you are searching in a browser, clear browser cache.
- From the Archiver web interface, select Configuration tab > from Overview of current settings > click Archive Stores
- Check the search index state for the archive store you are trying to search. Based on the state, perform the actions described below:
State Description Actions to be performed
Merging An archive store can not be searched while an index is merging. - If the index is stuck in merging state, select Archive Store from Archive Stores list and click on all indexes which are not in Online state.
- Restart all GFI Archiver services.
- Select the Archive Store from Archive Stores list and click on one index.
- Wait several minutes to see if index returns to Online state
- If the index returns to Online state, complete steps 3 and 4 until all indexes are Online.
- If the index fails to return to Online state, a rebuild will be required. Select Archive Store from Archive Stores list and click Rebuild Index
Online The index should be searchable. - Select Archive Store from Archive Stores list and click
- Compare Archive Store contains and Indexed emails from Archive Store Summary
- Active archive store may show a difference depending on mail flow and indexing frequency. Check indexing frequency.
- Non-active archive stores should match exactly. If numbers from above do not match, a rebuild will be required. Select Archive Store from Archive Stores list and click Rebuild Index.
Rebuilding An archive store cannot be searched while an index is rebuilding. The ability to search will resume once the search index is online. - To monitor rebuild status, select Archive Store from Archive Stores list and click
- Compare Archive Store contains and Indexed emails from Archive Store Summary.
- The number of Indexed emails should increase.
- If the number of Indexed emails does not increase, delete the index files:
- Stop the GFI Archiver services
- Browse to location for index files and delete the indexed files.
- Restart the GFI Archiver services
- Complete Archive Store Wizard:
- From the GFI Archiver web interface, select Configuration tab > from Overview of current settings > click Archive Stores
- Select Archive Store from Archive Stores list and click
- Monitor rebuild.
Invalid The index is most likely corrupt. - Select the Archive Store from Archive Stores list and click
- Complete Archive Store Wizard to confirm connection to database and index location.
- Select Archive Store from Archive Stores list and click Rebuild Index.
Paused - Select the Archive Store from Archive Stores list and click on one index.
- The index will return to the state which was before the Paused state.
- Follow steps based on the new index state.
Initializing An archive store cannot be searched while an index is initializing. - Confirm emails have been archived to the database, select Archive Store from Archive Stores list and click
- If the index remains stuck in initializing and all other indexes are online, select Archive Store from Archive Stores list and click Rebuild Index.
Pending An archive store cannot be searched while an index is pending. The ability to search will resume once the search index is online. - The search index will remain in Pending state if other indexes are being rebuilt.
- If the index remains stuck in pending and all other indexes are online, select Archive Store from Archive Stores list and click Rebuild Index.
Important Notes:
- Rebuilding a search index might take several hours, depending on the number of emails stored in the respective archive store.
- Rebuilding a search index impacts performance on the server, since this is a processor and hard disk intensive operation. It is recommended that this procedure is undertaken during off-peak hours, for example, after office hours.
- Always rebuild one index at a time for the reasons listed above.
- For best performance, ensure you are following the Best practices for GFI Archiver.