Overview
This article describes the issue, and its resolution when emails addressed to a mail-enabled public folder is not being archived by GFI Archiver.
Environment
- GFI Archiver
- All supported environments
Root Cause
Microsoft Exchange server does not journal emails which are addressed to public folders by default.
Resolution
GFI Archiver can archive emails addressed to mail-enabled public folders. This can be done as follows:
- Create a new windows security group from Active Directory Users and Computers.
- Create a new user with a mailbox and make the user a member of the security group created in step 1.
- Forward all posts addressed to the mail-enabled public folder to the user created in step 2.
- Set the appropriate Access permissions for users to be able to see archived emails for the public folder.
- From GFI Archiver, navigate to Configuration > Access Control, and configure each user to be a manager of the Windows Security Group created in step 1.
The procedure below explains how to forward all emails addressed to a mail-enabled public folder to a user:
For Microsoft Exchange 2013
- Open the Exchange Admin Center.
- Navigate to public folders.
- Click on the mail-enabled public folder you wish to archive and then click edit.
- Click delivery options.
- Enable the Forward to: feature, and choose the user previously created.
For Microsoft Exchange 2010/2007
- Open the Microsoft Exchange Management Console.
- In the console tree, click Toolbox.
- In the result pane, click Public Folder Management Console, and then in the action pane, click Open Tool. The Public Folder Management Console appears.
- In the public folder tree, right click on the mail-enabled public folder you wish to archive and select Properties.
- Under the Mail Flow Settings, select Delivery Options and select Properties...
- In the Delivery Options Window, enable the Forward to feature, and enter the email address of the user previously created.
For Microsoft Exchange 2003
- Open the Microsoft Exchange System manager.
- In the console tree, expand Folders then expand Public Folders.
- Right-click on the mail-enabled public folders and select Properties.
- Under the Exchange General Tab, click Delivery Options.
- In the Delivery Options Window, enable the Forward to feature and select the email address of the user previously created.