Overview
This article describes the process to import old emails contained within .PST files of a user who has been deleted or disabled within Active Directory.
Environment
- GFI Archiver
- All supported environments
Root Cause
By default, when importing .PST files of emails that do not match anything within Active Directory, those emails will only be able to be seen by a user that has the Full Access role to see All Users emails. The user account needs to be present and enabled within Active Directory to assign ownership correctly.
Process
To be able to see the emails under the desired deleted/disabled user name, the following should be performed:
- If the user was disabled in Active Directory, please re-enable them. If the user was deleted from Active Directory, please re-create this user.
NOTE: This will affect the enabled user count until the process is over. - Verify that all historical email addresses are correctly associated with the account within Active Directory.
- Run the Import-Export Tool as outlined in the Administrators Manual.
- If available to select an owner, verify that the correct user is selected.
- Log into Archiver with the credentials of that user (or a user that has Full Access permissions) and verify that the imported emails can be seen within their archive mailbox.
- Once verified that emails were imported correctly, the user's Active Directory account can then be deleted/disabled if so desired.
- Please restart the services to refresh the enabled user count.