Answer
PROBLEM
When Cached Exchange Mode is enabled within Microsoft Outlook, sent emails are not shown in the correct sub folder if they are moved as the Mailbox Folder Structure Retrieval feature does not synchronize such emails.ENVIRONMENT
- GFI Archiver
- All supported environments
SOLUTION
IMPORTANT:- Only consider this solution if disabling Cached Exchange Mode within Outlook is not suitable and if Sent Items must be synchronized
- This configuration change should only be implemented if the full impact of the change is understood
- This configuration change should be implemented at the time of installation (before any emails get archived)
- If this solution is implemented when emails have already been archived the Mailbox Folder Structure Retrieval feature will be unable synchronize emails which have been archived before this configuration change takes effect
- This procedure requires to edit files manually. If edited incorrectly it can leave the server in a non-operational state. Please keep backups of any file which is edited throughout this article before saving any changes to them.
- Stop all GFI Archiver services
- Create a backup of the following files
- ..\Archiver\Core\Data\CHSettings.xml
- ..\Archiver\Store\Data\CHSettings.xml
- Edit ..\Archiver\Core\Data\CHSettings.xml with notepad.exe
- Find the line which reads: <ADD_message_id>true</ADD_message_id>
- Change the string true to false (the line should read: <ADD_message_id>false</ADD_message_id>)
- Save the file
- Copy ..\Archiver\Core\Data\CHSettings.xml to ..\Archiver\Store\Data\ overwriting the existing file
- Start all GFI Archiver services
CAUSE
When Microsoft Outlook is running in Cached mode, the emails which are stored in the Sent Items folder in the mailbox are a copy of the email which is sent. However, a new Message ID is created for the message which is stored in the mailbox; this is different than the one used to send the email. The Message ID is one of the fields used when matching the emails in the Exchange mailbox with the emails archived in GFI Archiver.
Therefore, since the Message ID of the email in the mailbox does not match the Message ID of the email archived in GFI Archiver, the synchronization of sent emails will fail, and all the sent emails will be shown in the Sent Items folder.