Overview
This article resolves an issue where MailInsights reports are not being delivered to users via email. The below error message is logged in the SMTPSend.log file, under Core\DebugLogs\
:
#0000F424","#00000012","error ","SMTPSend","ERROR: Failed to process queue[SMTP protocol error. 550 5.7.1 Client does not have permissions to send as this sender.]"
Information
Environment
- Archiver
- Microsoft Exchange 2007 and 2010.
Root Cause
When a report is generated, the mailbox account specified in the General Settings is used to send the email (even though it appears to come from the logged-in user). For this to work, the account entered in the General Settings must have the same permissions as the logged-in user, specifically, the 'Send as.' If the proper permissions are not set, the above error message is generated, and the MailInsights reports will not be delivered.
Process
To resolve this, you will need to assign 'Send as' permissions to the affected users. To do this for Exchange 2007, follow the below instructions:
- Log in to the server running Exchange.
- Open Active Directory Users and Computers.
- Under the View menu, enable the Advanced Features option (if disabled).
- Locate the account of the user to which you want to assign the 'Send as' permission, right-click on it and select Properties.
- Select the Security tab.
- Under Group or user names, click Add to add the users or group that is to be granted permission to.
- For each account added, highlight the account under Group or user names, and in the Permissions for window, grant 'Send As' permission to the account.
- Click OK to close the dialog.
Refer to Manage Send As Permissions for a Mailbox for instructions on how to assign 'Send as' permissions in Exchange 2010.