Overview
When using Archiver with a Microsoft 365 mailbox, we recommend disabling moving deleted items to the Recoverable Items folder. This prevents your journal mailbox from filling up and reaching its size limit.
Diagnosis
The Journaling Mailbox is filling up with deleted items and administrators are unable to empty the Deleted items folder.
Important notes:
- When the maximum capacity is reached, Archiver will not be able to archive emails.
-
The Recoverable Items folder is a hidden folder that contains emails deleted in Microsoft 365 for a specific amount of time (default 14 days). Quotas for Recoverable items cannot be increased.
- When you disable this functionality, emails are automatically deleted from the journal mailbox once GFI Archiver successfully downloads the emails.
Solution
For more information regarding the below steps, please refer to the Microsoft Support article Connect to Exchange Online PowerShell.
- On a Windows machine, open Terminal or PowerShell.
- Run the following command:
Import-Module -Name ExchangeOnlineManagement
- if the module could not be found, you might want to
Install-Module -Name ExchangeOnlineManagement
from PSGallery (PowerShell 7.2 and above is recommended)
- if the module could not be found, you might want to
- To start your remote session with Exchange Online, run the following command:
Connect-ExchangeOnline -UserPrincipalName {{yourMSLoginEmail}}
- a browser tab should open to authenticate and/or confirm MFA
- To disable the Recoverable Items folder functionality, run the following command:
Set-Mailbox –Identity {{journalMailboxEmailOrUsername}} -SingleItemRecoveryEnabled $False -RetainDeletedItemsFor 0
- To disconnect your session:
Disconnect-ExchangeOnline
To verify the steps have been implemented properly for the Journaling Mailbox you can refer to the external article: Delete the items in the Recoverable Items Folder.